Author Topic: "JUN" 67' bug  (Read 9012 times)

0 Members and 1 Guest are viewing this topic.

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
"JUN" 67' bug
« on: July 19, 2010, 02:48:00 PM »
Hello All!!!

Name is Rich, this is "Jun" and she is a 67' bug with a SP 1600.  I'm quite new to the aircooled game and still learning.  Thanks for having me on board!!! ;D

Offline slammed66

  • Administrator
  • Hero Member
  • *****
  • Posts: 426
Re: "JUN" 67' bug
« Reply #1 on: July 19, 2010, 10:13:27 PM »
i love the color scheme, some people hate on the white rubers but that thing looks like a creamsickle

tiiiiiiiiiiiiiiiiggggggggghhhhhhhhhhhhhttttttttttttt!

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #2 on: July 20, 2010, 02:33:13 AM »
slammed66:  THANKS!!!  Got this bug through a trade.  The guy said he wasn't a bug guy.  What's there not to love?  ???

Offline 64Notch

  • OG Luftvolks
  • Hero Member
  • *********
  • Posts: 291
Re: "JUN" 67' bug
« Reply #3 on: July 20, 2010, 10:38:24 AM »
Good to have you on board.  Hopefully you can keep Tone Busy out there........  Nice Bug by the Way.....

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #4 on: July 22, 2010, 06:22:31 PM »
i think he's in sacto?  i'm in the east bay, oakland area....

Offline 64Notch

  • OG Luftvolks
  • Hero Member
  • *********
  • Posts: 291
Re: "JUN" 67' bug
« Reply #5 on: July 25, 2010, 01:55:04 AM »




























Thats close enough

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #6 on: July 25, 2010, 12:44:25 PM »
Somewhat?...  Yo, Luft what part of Sacto you in?...  I used to live in Carmichael

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: "JUN" 67' bug
« Reply #7 on: July 25, 2010, 02:35:38 PM »
More west....close to the college.

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #8 on: July 26, 2010, 01:34:27 AM »
Downtown?  Arden Fair?  or Folsom area?...  How you like it?  Half country, half city... 

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #9 on: July 28, 2010, 11:32:17 PM »
All right here's an update on "JUN"...  Here's some pics on "JUN" transforming into "JUN-stien"....

[url][/url]
Stock SP1600 w/ stock exhaust
[url][/url]
Now the transformation begins.....  1st pulled the motor
[url][/url]
2nd the EFFIN' seals and they were a BITCH to put on... When I got her, she didn't have any  
[url][/url]
3rd bolted on the headers.  We also did a test fitting with the dual carbs to see if everything sat nicely.  Some modifications was needed
[url][/url]
« Last Edit: July 28, 2010, 11:56:31 PM by scratchyratchy »

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #10 on: July 29, 2010, 12:01:18 AM »
4th...  This is how she looked like when everything was done.  The exhaust was made by my buddy Frank and trying tune the carbs was Alex (in the pic.)  We had some test runs around the block, but she was coughing bad.  
[url][/url]

We couldn't figure out what was wrong with her?  Now, I'm in the city at Frank's house working on "JUN' all day and I live in The East Bay area.  We tried to tune her as much as we can just so I can go home....  and this is what happened trying to go home that night
[url][/url]
[url][/url]
Wife wasn't too happy....  Anyways, just finished tunning her up this past Monday and she sounds like a tiger and runs like a cheetah....  Will post some more pics tomorrow
« Last Edit: July 29, 2010, 12:10:17 AM by scratchyratchy »

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: "JUN" 67' bug
« Reply #11 on: July 29, 2010, 11:57:25 AM »
YES, a greasefest!! Sorry the outcome wasnt a positive one until later. Im sure your getting better mileage with the header and duals now along with MORE POWER!

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #12 on: July 29, 2010, 12:48:42 PM »
 ;D ...  Yes, if you don't leave your foot on the throttle....lol     

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #13 on: August 02, 2010, 12:52:46 PM »
Well, here's how she looks now...  engine bay don't look to nice, but she sure has a GOOD heartbeat and a WICKED behind....  Will be moving the fuel filter under the carriage or under the left fender?...Painted the exhaust with some VHT spray didn't like the shiny crap...  Will be putting back my stock exhaust, apparently it's hi po stock looking one...

[img][/img]
[img][/img]

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: "JUN" 67' bug
« Reply #14 on: August 02, 2010, 11:37:37 PM »
Yes, move the fuel filter ASAP! I put mine by the transmission right were the steel fuel line comes out of the pan. A bit of a PITA to change but if it leaks its only under the car not on top of high voltage source!!

Also secure your fuel lines, I had one get sucked into the fan and get chewed up, NOT FUN!