Author Topic: "JUN" 67' bug  (Read 9441 times)

0 Members and 1 Guest are viewing this topic.

Offline 64Notch

  • OG Luftvolks
  • Hero Member
  • *********
  • Posts: 291
Re: "JUN" 67' bug
« Reply #15 on: August 03, 2010, 01:25:25 AM »
Looks good Rich.  Those towing days bring back memories.  My wife would of told me to walk home........I like that exhaust, what manufacturer did that style come from.....

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #16 on: August 03, 2010, 06:33:34 PM »
Thanks 64...  It doesn't say the manufacture only says MADE IN THE USA!!!... lol 
Actually, my buddy Frank had the muffler and 1 3/8" exhaust and welded a bend (shown on the pic) on it.  Sticked out a bit and it was HELL'A LOW!!!  1" or 2" off the ground?  Took it out and now replacing it with my stock hi-po exhuast....

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: "JUN" 67' bug
« Reply #17 on: August 04, 2010, 12:42:22 AM »
just a warning, the "stock hi po exhausts" suck

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #18 on: August 04, 2010, 12:51:14 AM »
lol....  thanks  ::)

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #19 on: August 16, 2010, 12:18:45 AM »
Update:

I know, I know...  She is up for sale, but I am still fixing on her.  Got new rear engine tin (without breathers, but with heatrisers), a set of SP manifolds (will be practicing my polishing ;)), and a 019 dizzy....  Will post some pics soon...

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: "JUN" 67' bug
« Reply #20 on: August 16, 2010, 12:40:36 AM »
Keep on working, sometimes if they make you bleed enough you can bring yourself to sell. In this market I would put it up for trade and see what you can get, you may come up on some cool as rides like you did with this bug!

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #21 on: August 16, 2010, 11:03:58 PM »
True that, but the other bug I'm eyeing is a 65'.  Really want to get it so bad, but I got's to sell "JUN" first.....

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #22 on: October 29, 2010, 09:42:34 PM »
Just wanted to post some pics of "JUN"...  this how she looks nowadays

took out the roof rack, i actually like the way it looks without it...  added a different steering wheel, flipped the sideview mirror upside down...  next i will be re-upholstering the lowbacks with mexican blankets and adding a bus shifter for that "ginny" look...  updates to follow
[img][/img]
[img][/img]
[img][/img]

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #23 on: November 21, 2010, 01:11:43 PM »
just this past wednesday, a friend i worked on "jun"...  we tried to install an 019, but found out that it was missing the insulator.  found out we could've used a matchbook and cut to size...  so, we installed my friend's 009 for now. 

changed the plugs, wires, exhaust, added a bus shifter for that "ginny" look...  outcome:  RUNNING LIKE A CHAMPION!!!

pics to follow when the weather gets better...
« Last Edit: November 21, 2010, 01:23:23 PM by scratchyratchy »

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #24 on: November 24, 2010, 02:50:45 PM »
that's CHUPA (short for chupa me v***a) on my mirror...  since i read the site issue, had to CENSORED the word

[img][/img]
[img][/img]
« Last Edit: November 28, 2010, 06:36:26 PM by scratchyratchy »

Offline 64Notch

  • OG Luftvolks
  • Hero Member
  • *********
  • Posts: 291
Re: "JUN" 67' bug
« Reply #25 on: November 28, 2010, 11:16:37 PM »
Tiiiiiiigggghttttt!

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
Re: "JUN" 67' bug
« Reply #26 on: November 30, 2010, 06:44:13 PM »
added a tray and an 8 ball today....

[img][/img]
[img][/img]
[img][/img]
« Last Edit: December 03, 2010, 05:23:06 PM by scratchyratchy »

Offline scratchyratchy

  • Nor Cal Luftvolks
  • Hero Member
  • *****
  • Posts: 285
  • MARTY!!!
"jun" da 67 bug
« Reply #27 on: June 03, 2011, 12:29:48 AM »
today i painted the 3" plates and slapped the decals on...
[img][/img]
went to my boys house and did some wrenching and hammering and ended up with this...
[img][/img]
[img][/img]

next up is the beam...
« Last Edit: June 05, 2011, 01:47:47 PM by scratchyratchy »

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: "JUN" 67' bug
« Reply #28 on: June 03, 2011, 04:14:31 AM »
merged them for you.

Damn that thing is LOW!! Better start stocking up on rear wheel bearings, with that much camber no gear oil will lubricate it so it will burn up faster. Maybe think of putting a sealed bearing so at least you can grease that puppy up.

Offline slammed66

  • Administrator
  • Hero Member
  • *****
  • Posts: 426
Re: "JUN" 67' bug
« Reply #29 on: June 03, 2011, 11:23:00 AM »
I can't see pics. But do like I do and make an occasional hard left and hard right to make hear oil go up to the bearings

I also don't do a whole lit of freeway miles