Author Topic: Natalie's 69  (Read 5008 times)

0 Members and 1 Guest are viewing this topic.

Offline theragingbuffalo

  • OG Luftvolks
  • Full Member
  • *********
  • Posts: 164
Natalie's 69
« on: December 25, 2009, 03:48:27 PM »











Offline theragingbuffalo

  • OG Luftvolks
  • Full Member
  • *********
  • Posts: 164
Re: Natalie's 69
« Reply #1 on: December 25, 2009, 03:51:55 PM »







Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: Natalie's 69
« Reply #2 on: December 31, 2013, 02:16:07 PM »
When I needed the same part for the 70 vert the only place that had it was Russ' Recycling in Irwindale

http://www.yelp.com/biz/russ-recycling-irwindale

Offline theragingbuffalo

  • OG Luftvolks
  • Full Member
  • *********
  • Posts: 164
Re: Natalie's 69
« Reply #3 on: December 31, 2013, 02:55:34 PM »
Thanks I am waiting for a call back from Bill and Steves, they think they have one.

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: Natalie's 69
« Reply #4 on: December 31, 2013, 08:24:26 PM »
Here are some if local sources come up short

http://www.thesamba.com/vw/classifieds/detail.php?id=1575014


Offline theragingbuffalo

  • OG Luftvolks
  • Full Member
  • *********
  • Posts: 164
Re: Natalie's 69
« Reply #5 on: January 02, 2014, 12:32:15 PM »
Well I picked up one this.morning. Bill & Steve's had one for a later model that would.have  worked but I would have to change the keyy barrel to.a.later model as well. I found a new one at Vintage in Valencia. I paid a bit more for it because it is new, and they don't make them anymore. That is why I couldn't find one. But at least it is the correct one. I will change that out today and hope it starts! Then I am going to pull the motor and change the tranny mounts!

Offline LUFTVOLKS

  • Administrator
  • Hero Member
  • *****
  • Posts: 809
  • BangBusBaby!!
Re: Natalie's 69
« Reply #6 on: April 01, 2014, 06:45:38 PM »
Back and recovered from camping, whats going on with the bug?